Netgear R7000 LEDs ausschalten mit dd-wrt

Gespeichert von Michael Kirgus am So., 02.10.2016 - 16:13

Vor einigen Monaten habe ich mir den Netgear R 7000 einmal genauer angesehen und war mit der Leistung zufrieden. Also entschloss ich mich, den Router in unserem Netzwerk produktiv einzusetzen. Doch nach einigen Tagen (vor allem Nachts) stört mich das sehr helle Licht der LEDs.

In der Orginalversion der Firmware von Netgear gibt es seit neustem die Funktion, die LEDs abzuschalten. Also musste dies mit wenig Aufwand eigentlich auch unter dd-wrt möglich sein. Wie auch z.B. bei einem Raspberry Pi funktioniert die Ansteuerung der LEDs und Buttons auch hier mittels GPIO.

Nach einiger Suche im Internet fand ich die Belegung der GPIO-Ports:

2,3,8,9,12,13,17,18 und 0 müssen an und 14+15 müssen ausgeschaltet sein.

Also per Telnet auf den Router verbunden und die Ports nacheinander umgeschalten:

Und siehe da, es sind nun nur noch die LAN-Ports an, welche man nicht ohne weiteres deaktivieren kann, da diese durch eine andere Komponente (Switch) gesteuert werden. So hat man wieder etwas (wenn auch wenig) Strom eingespart und Nachts kann man wieder ohne geblendet zu werden durch den Flur schreiten.

UPDATE: Natürlich sind diese Einstellungen bei einem Neustart des Routers wieder zurückgesetzt. Deshalb ist es sinnvoll, die Befehle als Startup-Script unter dd-wrt zu hinterlegen. Hierzu im Tab "Administration" unter "Diagnose" in dem Textfeld "Kommandos" die Befehle eingeben und unten auf den Button "Startup speichern" klicken:

Hier noch einmal für fürs Copy & Paste:

gpio enable 2
gpio enable 3
gpio enable 8
gpio enable 9
gpio enable 12
gpio enable 13
gpio disable 14
gpio disable 15
gpio enable 17
gpio enable 18
gpio enable 0

Neuen Kommentar hinzufügen

Sind Sie ein Mensch? Schlimm, aber leider notwendig:

Bild-CAPTCHA
Geben Sie die Zeichen ein, die im Bild gezeigt werden.